Comment installer le runtime Java SE 6 hérité sur MacOS



Si vous essayez de lancer un programme Adobe CS6 ou CS5 (Photoshop, Illustrator, InDesign, etc.) sur OS X Yosemite ou une version ultérieure, vous êtes probablement confronté à un problème.
Après avoir double-cliqué sur certaines des applications Adobe, un message s’affiche pour vous informer que pour ouvrir l’application, vous devez installer l’ancien moteur d’exécution Java SE 6.



En plus des packages Adobe CS5 et CS6, d’autres applications nécessitent Java SE 6 Runtime.
(Eclipse, PDF Studio 9, FileMaker Pro Advanced, Patch Tool, Dreamweaver, voire le célèbre jeu Minecraft).


Ce problème se produit car ces applications (Adobe CS5, CS5, etc.) dépendent de Java 6. Mac OS X Yosemite (et les versions plus récentes) ont une version ultérieure de Java Runtime (SE 8.0).
Cependant, Java Runtime n’est pas rétrocompatible. Par conséquent, même lorsque le système d’exploitation a installé Java Runtime 8, il n’exécutera PAS les applications qui dépendent de Java Runtime 6. Voici comment obtenir Java 6 sur votre Mac.


Installer Legacy Java SE 6 : Méthode n° 1


Remarque : vous pouvez installer Java SE 8 et Java SE6 sur votre ordinateur sans problème.
De plus, vous n’avez PAS besoin de désinstaller SE 8, puis d’installer SE 6.



  1. Lorsque la fenêtre contextuelle apparaît sur votre écran (vous demandant d’installer le runtime Legacy Java 6), cliquez sur le bouton Plus d’informations

  2. Maintenant, un site d’assistance Apple se chargera et vous donnera des instructions supplémentaires sur la façon d’obtenir l’environnement d’exécution Java 6.

  3. Suivez ces instructions et téléchargez le programme d’installation de Java Runtime 6 sur votre Mac.

  4. Une fois que vous avez terminé, double-cliquez sur le fichier.
    dmg pour lancer le programme d’installation.

  5. Suivez les instructions à l’écran pour terminer l’installation.


Installer Legacy Java SE 6 : Méthode n° 2


Si la méthode ci-dessus n’a pas fonctionné, essayez ce qui suit.


  1. Accédez au lien suivant https://support.apple.com/kb/DL1572?locale=en_US

    Si ce lien ne fonctionne pas, essayez ce lien direct http://download.info.apple.com/Mac_OS_X/031-03190.20140529.Pp3r4/JavaForOSX2014-001.dmg


  1. Téléchargez Java SE 6 pour OSX (cliquez sur le bouton de téléchargement)

  2. Une fois le téléchargement terminé, installez le fichier dmg en suivant les instructions à l’écran.


Lorsque le runtime Java 6 est installé sur votre Mac, vous pouvez lancer Adobe CS5 (ou toute autre application nécessitant le runtime Java 6).



Remarque : Vous n’avez PAS besoin de redémarrer votre Mac avant de lancer l’application.


Deja un comentario